Home Forums WP Content Resharer Pro The automatic publication stopped working

This topic contains 11 replies, has 3 voices, and was last updated by  sergiohernandez 10 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #22585

    sergiohernandez
    Participant

    After working properly the plugin stopped working.

    I deleted, and reinstalled the plugin and it does not work.

    I checked the Cron Event Plugin and only found the event to check the plugin updates, there is no other event.

    Could you give me an idea where the problem might be? or tell me the instructions to add the Event to the Cron

    Thanks for your attention

    #22586

    Jay Gajjar
    Keymaster

    Hello Sergio,

    Welcome to the community :)

    We tested the plugin on our end, and both, the Reshare Now and autosharing (standard resharing) work fine. So we can conclude that the issue is caused due to the Cron Event plugin.

    Do you see a message saying that WP Cron is disabled on your WordPress dashboard?

    If not could you please install WP Control instead of WP-Cron Events

    And then:
    1. Go to WordPress dashboard > Tools > Cron Events
    2. Look for wpsite_reshare_0 (or 1)
    3. Click on “Run Now”
    4. Check your Facebook page/Twitter Feed to see if you have any post from the your page

    Please let me know what happens.

    #22587

    sergiohernandez
    Participant

    I installed the WP-Crontrol plugin

      Looked for wpsite_reshare_0 and clicked “Run Now”

    apparently the process did correct, but no publication was made.

    I did the test, desistalando all the plugins and still, it does not work

    #22588

    sergiohernandez
    Participant

    I’m noticing that I deactivate the plugin and reactive again, a publication is made, but later the automatic publications are no longer done …

    #22591

    Jay Gajjar
    Keymaster

    Please make sure to check if there are any limitations to as to the time frame, decided to publish your posts.

    If so, have you tried posting between the hours that are not being excluded?

    Also, make sure your timezone is configured properly at WordPress dashboard > Settings > General.

    #22592

    Charlie
    Keymaster

    If possible, you may also want to create a new dummy install with just the plugin and see if it works. If it does not, then it’s possible that your server has some limitation in place related to cron.

    If it does work, then your existing site has some configuration that is the constraint. If deactivating all other plugins did not render a working result, then I would guess it has more to do with server configuration related to crons (talk to your host).

    Hope that additional info helps. Thank you.

    #22593

    sergiohernandez
    Participant

    Jay:

    There is no limitation in the configuration …

    Charlie:

    I’m going to make the test you recommend … and comment on the result …

    Thank you

    #22594

    sergiohernandez
    Participant

    I installed the plugin in other site in the same VPS and it still does not work.

    However I installed it in a site in another hosting and it works correctly …

    Apparently it must be problem of the configuration of the VPS, I already reported it to the support but if you have some suggestion to know where to look, I would appreciate it.

    Regards!

    #22595

    Jay Gajjar
    Keymaster

    It’s likely the host is preventing the cron from running. Therefore, please ask your host to enable the cron for your WordPress install or to ensure the wp-cron is not limited by them. Let them know that you have a cron that needs to run every couple of minutes.

    Please keep us updated with the results.

    Thank you,

    #22596

    sergiohernandez
    Participant

    I have continued to investigate and doing tests, and I found the fault.

    The problem is in the incompatibility of the plugin with the “Newspaper” Theme

    apparently this theme has problems with several plugins that use cron

    #22597

    Charlie
    Keymaster

    Hi Sergio – Great find. Unfortunately, crons should never be impacted by a theme. So it’s surprising to hear that Newspaper theme causes those issues. Many plugins will have their own crons required. So will core WP which has to run crons too. A theme should NOT impact another plugin or WP core’s cron jobs.

    If you report to the Newspaper theme developer, I’m sure they’ll be able to solve it.

    #22598

    sergiohernandez
    Participant

    The problem is a bad call to a function (missing the parameter variable :-))

    It has been reported by several users, apparently they have corrected it in some files, but they have not corrected it in another file where the call is made.

    I modified it manually and it works correctly.

    Thanks for the support

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Pin It on Pinterest